Настройка L2TP-Over-IPsec на Cisco IOS

aaa new-model
!
aaa authentication login default local
aaa authorization network default local
!
vpdn enable
!
vpdn-group L2TP
! Default L2TP VPDN group
accept-dialin
protocol l2tp
virtual-template 1
lcp renegotiation on-mismatch
no l2tp tunnel authentication
ip pmtu
ip mtu adjust
!
username testuser privilege 0 password testpass
!
crypto isakmp policy 10
encr 3des
authentication pre-share
group 2
lifetime 3600
crypto isakmp key SECRET_KEY address 0.0.0.0 no-xauth
crypto isakmp keepalive 3600
!
crypto ipsec transform-set L2TP_SET esp-3des esp-sha-hmac
mode transport
!
crypto dynamic-map L2TP_MAP 10
set nat demux
set transform-set L2TP_SET
!
crypto map L2TP_CRYPTO_MAP 10 ipsec-isakmp dynamic L2TP_MAP
!
interface Loopback1
ip address 172.31.1.1 255.255.255.0
!
interface GigabitEthernet0/0
description -= WAN =-
ip address XXX.XXX.XXX.2 255.255.255.252
ip nat outside
crypto map L2TP_CRYPTO_MAP
!
interface GigabitEthernet0/1
description -= LAN =-
ip address 192.168.0.1 255.255.255.0
ip nat inside
!
interface Virtual-Template1
ip unnumbered Loopback1
ip nat inside
peer ip address forced
peer default ip address pool L2TP_POOL
ppp encrypt mppe 40
ppp authentication ms-chap-v2
ppp ipcp dns 192.168.0.1
!
ip local pool L2TP_POOL 172.31.1.10 172.31.1.250
!
ip nat inside source list INET_ACL interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 XXX.XXX.XXX.1
!
ip access-list extended INET_ACL
permit ip 192.168.0.0 0.0.0.255 any
permit ip 172.31.1.0 0.0.0.255 any

28.09.2017 · XDriver · Комментариев нет
Метки:  · Рубрики: Cisco

Настройка IPSec+GRE+OSPF на Cisco IOS через Crypto-Map

crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share

crypto isakmp key 123456 address 10.10.20.1
crypto ipsec transform-set TUNNEL_SET esp-3des esp-md5-hmac
mode tunnel

crypto map TUNNEL 10 ipsec-isakmp
set peer 10.10.20.1
set transform-set TUNNEL_SET
match address 100

interface Tunnel0
description -= REMOTE_SIDE =-
ip address 10.0.0.1 255.255.255.252
ip ospf 1 area 0
tunnel source Fa0/1
tunnel destination 10.10.20.1

interface Fa0/0
description -= LAN =-
ip address 192.168.1.1 255.255.255.0
ip ospf 1 area 0

interface Fa0/1
description -= WAN =-
ip address 10.10.10.1 255.255.255.0
crypto map TUNNEL

router ospf 1
log-adjacency-changes

ip route 0.0.0.0 0.0.0.0 10.10.10.2 name ISP

access-list 100 permit gre host 10.10.10.1 host 10.10.20.1

12.09.2017 · XDriver · Комментариев нет
Метки:  · Рубрики: Cisco

Простая настройка IPSec+GRE+OSPF на Cisco IOS

crypto isakmp policy 10
encr aes
authentication pre-share
group 2
crypto isakmp key 123456 address 10.10.20.1
!
crypto ipsec transform-set IPSEC esp-aes 192 esp-sha-hmac
!
crypto ipsec profile IPSEC
set transform-set IPSEC
!
interface Tunnel0
ip address 10.0.0.1 255.255.255.252
ip ospf 1 area 0
tunnel source FastEthernet0/1
tunnel destination 10.10.20.1
tunnel mode ipsec ipv4
tunnel protection ipsec profile IPSEC
!
interface FastEthernet0/0
description -= LAN =-
ip address 192.168.1.1 255.255.255.0
ip ospf 1 area 0
!
interface FastEthernet0/1
description -= WAN =-
ip address 10.10.10.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
!
ip route 0.0.0.0 0.0.0.0 10.10.10.2 name ISP

11.09.2017 · XDriver · Комментариев нет
Метки:  · Рубрики: Cisco

Не стартует Asterisk: Unable to query table description!

Если Вы не уследили за местом на жестком диске сервера Asterisk, служба asterisk может вести себя неадекватно из-за невозможности создавать временный файл.

Но даже после того, как место очищено, служба asterisk все равно не стартует, а в консоли постоянно выдается сообщение:

Asterisk ended with exit status 1. Asterisk died with exit status 1. Asterisk died with code 1

Но из-за того, что Asterisk не стартует, важно понять, какой процесс его блокирует.

Первым делом смотрим в лог Астериска:
tailf /var/log/asterisk/full

В самом последнем этапе запуска Астериска видна такая строка:

cdr_mysql.c: Unable to query table description!! Logging disabled.

Эта строка говорит о том, что модулю cdr_mysql.so не получилось запуститься. Чаще всего это может говорить о том, что база данных и таблицы MySQL повреждены.

Чтобы восстановить базу данных MySQL, выполняем следующие команды:
service asterisk stop
service mysqld stop
mysql -u root -p
>repair table asteriskcdrdb.cdr;
service mysqld start
service asterisk start
asterisk -rvvv

В консоли Астериска проверяем работу cdr:
cdr show status

Все готово! Следите за местом на сервере и не допускайте переполнения!

18.05.2017 · XDriver · Комментариев нет
Метки:  · Рубрики: Linux

КОСМОС НАЧИНАЕТСЯ С БЕРЕГОВ ОЗЕРА ЭЛЬТОН

Одно из совершенно чудесных мест в России расположено в Волгоградской области, на границе с Казахстаном. Называется оно — озеро Эльтон. Если добираться из столицы нашей Родины — чуть менее суток пути на поезде до Волгограда, а оттуда на автобусе часов шесть, до поселка городского типа Эльтон. На машине получается быстрее и удобнее. Тем же, кто живет на юге России, и имеет свой транспорт, съездить туда просто настоятельно рекомендую.

Пропущу свою дорогу от Краснодара до Эльтона, и сразу перейду к рассказу. По дороге, как это у нас водится — степь да степь кругом. Ощущается, что совсем неподалеку Казахстан с его солончаками и джейранами. Иногда это зверье можно и тут заметить.

На въезде в Эльтон — стелла, напоминающая по цвету белую-белую соль. Не ошибетесь, мимо не проедете, да и, собственно, некуда. Остановиться в Эльтоне можно в санатории, только если места заранее забронируете, летом часто не бывает свободных номеров. Также привечают в поселке путешественников местные жители. Можно и поставить палатку.

До Эльтона можно доехать на машине почти до самого озера. Если, конечно, ехать не со стороны местного Большого каньона. Он похож на тот самый, в Аризоне, где снимают кино про Марс.

При приближении к озеру появляются сюрреалистические, будто иномировые приметы: красная просоленная, как будто застывшая во льду растительность. Это траву облепили водоросли и соль, когда она была под водой.

Когда видишь само озеро, в груди все замирает, и кажется, что ты попадаешь в другой мир. Здесь просто потрясающе красиво, нет, даже не так — великолепно.

Эльтон — бессточное соленое озеро, расположенное на Прикаспийской низменности. До Каспия здесь далеко, а вот низменность — это ощущается. Поверхность озера гладкая, само оно мелкое, и, ступая по воде, будто идешь по небу. Линии горизонта иногда не видно совсем.

Это самое большое минеральное озеро Европы. В конце лета из-за водорослей воды его окрашиваются в фантастические пурпурный или золотой цвета, и, говорят, от этого и произошло название водоема. По-монгольски «алтн нор» — «золотое дно». Правда, золота тут нет, и с металлоискателем, наверное, ходить бесполезно — почва так просолена, что копни — и этим можно солить гречку с тушенкой.

Кристаллы соли встречаются везде. По верху озера ходит рапа — насыщенный соляной раствор. Минерализация его составляет 200—500 г/л, что в 1,5 раза превышает концентрацию на Мертвом море. На дне озера — залежи солей (той самой, поваренной, которая NaCl, и калийной — Kcl). Говорят, здесь еще при Иване Грозном начали добывать соль.

Под солевым пластом — слой минеральной сероводородной грязи. Часто можно видеть туристов, которые обмазываются грязью. От этого кожа становится мягкой и чистой, как у малыша. Ну, если потом как следует смыть грязь — сначала в очень-очень соленой воде Эльтона, а затем в речушке, которая впадает в него. Здесь есть такие, и их несколько. Останавливаться и ставить палатку лучше у них.

Закаты на Эльтоне — будто огромный пожар на полнеба и всю землю. Легко представить, что вы на другой планете с отсутствием атмосферы и феерически ярким светилом.

На рассвете же все может стать розовым — и водная гладь, и небо. Розовое! По небу можно ходить…

Но самое потрясающее — это ночь. В небе видны звезды, настолько крупные, что просто не верится, что ты без телескопа. И эти звезды — до их сияния можно дотянуться рукой. Захватывает дух от красоты. Куда там всяким заграницам! Такую красоту, наверное, нигде в мире не увидеть…

Величие природы, неба, Вселенной, наконец — все это здесь, вокруг вас, и космос вращается вокруг человека. Ощущение потрясает до глубины души.

Чудесно. Никогда не жалейте времени на путешествия. И вам откроется дверь в совершенно другой, прекрасный и яростный мир.

09.04.2017 · XDriver · Комментариев нет
Рубрики: Интересно, Туризм

6 ссылок о том, что Google знает о вас

Не желаете ли узнать о том, что Google знает о вас? Вот 6 ссылок, которые покажут вам некоторые данные, собранные гуглом.

1. Ваш профиль в Google
Google создаёт профиль с вашими основными данными – возраст, пол, интересы. Эти данные используются для показа релевантных объявлений. Вы можете просмотреть эту информацию здесь:

www.google.com/ads/preferences/

2. История ваших перемещений
Если у вас есть устройство на Android, оно может отправлять ваш координаты и скорость в Google. Вы можете посмотреть свою историю перемещений и вывести её в файл:

maps.google.com/locationhistory

3. Ваша история поиска в Google
Google может сохранять историю вашего поиска. Кроме того, он сохраняет историю объявлений, по которым вы кликнули. Всё это доступно здесь:

history.google.com

(прим: эту возможность надо включить в своём аккаунте)

4. Список устройств, получавших доступ к вашему аккаунту
Если вас интересует, не пользуется ли вашим аккаунтом кто-то ещё, вы можете посмотреть список всех устройств, которые получали к нему доступ, их IP-адреса и местоположение:

security.google.com/settings/security/activity

5. Список всех приложений и расширений, обращающихся к вашим данным в Google
Список всех приложений, у которых есть какой-либо доступ к вашим данным. Можно видеть, какие права у них есть и к чему у них есть доступ. Можно также отозвать этот доступ.

security.google.com/settings/security/permissions

6. Google на вынос
Можно экспортировать все ваши данные – закладки, почту, контакты, календарь, файлы с Drive, видео с youtube, фотки и прочее:

www.google.com/takeout

26.05.2016 · XDriver · Комментариев нет
Метки:  · Рубрики: Интересно

5 историй с моралью

1. Однажды мышь заметила, что хозяин фермы поставил мышеловку. Она рассказала об этом курице, овце и корове. Но все они отвечали: “Мышеловка — это твои проблемы, к нам она никакого отношения не имеет!”
Чуть позже в мышеловку попалась змея — и укусила жену фермера. Пытаясь ее излечить, жене приготовили суп из курицы. Потом зарезали овцу, чтобы накормить всех, кто приехал навестить больную. И, наконец, закололи корову, чтобы достойно накормить гостей на похоронах.
И все это время, мышь наблюдала за происходящим через дырочку в стене и думала о вещах, которые ни к кому никакого отношения не имеют!

Мораль: Если Вас что-то не касается напрямую, не думайте, что это что-то не ударит Вас по голове

2. Орел сидел на дереве, отдыхал и ничего не делал.
Маленький кролик увидел орла и спросил:
— “А можно мне тоже сидеть, как Вы, и ничего не делать?”
— “Конечно, почему нет”, — ответил тот.
Кролик сел под деревом и стал отдыхать. Вдруг появилась лиса, схватила кролика и съела его.

Мораль истории: чтобы сидеть и ничего не делать, Вы должны сидеть очень, очень высоко.

3. На ферме заболел конь.
Ветеринар:
— Если утром он не встанет, я его усыплю.
Утром конь не встал. Рядом лежал баран:
— Ну давай вставай или ты умрёшь!
Конь встал.
Фермер:
— Это чудо! Это надо отпраздновать! По такому случаю мы зарежем барана!

Мораль: Никогда не лезьте не в своё дело (но не забывайте об истории с мышеловкой).

4. Три человека ворочали камни. Одного из них спросили: – Что ты делаешь?
Он вытер пот со лба и ответил: – Горбачусь.
Подошли ко второму и спросили: – А ты что делаешь?
Он закатал рукава и деловито сказал: – Деньги зарабатываю.
Спросили у третьего: – А что делаешь ты?
Он посмотрел вверх и сказал: – Храм строю.

Мораль: жизнь наполнена смыслом только у того, кто преследует великую цель.

5. Таксист подвозит известного в городе миллионера. Тот расплачивается ровно по счетчику.
Таксист:
— Я вчера вашего сына подвозил, так он мне 100 долларов на чай оставил.
— Ну так что вы хотите: у него папа — миллионер, а я — сирота.

Мораль: только тот, кто сам заработал свои деньги, по настоящему знает им цену.

26.05.2016 · XDriver · Комментариев нет
Метки:  · Рубрики: Интересно

Решаем проблему совместимости Cisco и SFP

Столкнулся недавно с проблемой. А суть ее такова: есть коммутатор Cisco 3560E и в нем есть модуль для подключения SFP. Если вставить родные SFP от Cisco, то все работает; если же подключить SFP модуль стороннего производителя, тогда коммутатор не будет принимать этот модуль.

При подключении SFP модуля стороннего производителя в логи коммутатор пишет вот что:

00:40:35: %GBIC_SECURITY_CRYPT-4-VN_DATA_CRC_ERROR: GBIC in port Gi0/25 has bad crc
00:40:35: %PHY-4-UNSUPPORTED_TRANSCEIVER: Unsupported transceiver found in Gi0/25
00:40:40: %GBIC_SECURITY_CRYPT-4-VN_DATA_CRC_ERROR: GBIC in port Gi0/26 has bad crc
00:40:40: %PHY-4-UNSUPPORTED_TRANSCEIVER: Unsupported transceiver found in Gi0/26

Решить эту проблему достаточно просто. Заходим на коммутатор и «заставляем» коммутатор принять наши модули стороннего производителя при помощи команд:

service unsupported-transceiver
no errdisable detect cause gbic-invalid
no errdisable detect cause sfp-config-mismatch

15.01.2016 · XDriver · Комментариев нет
Метки: ,  · Рубрики: Cisco

Репозитории EPEL RHEL/CentOS 7/6/5

## RHEL/CentOS 7 64-Bit ##
wget http://dl.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-5.noarch.rpm
rpm -ivh epel-release-7-5.noarch.rpm

## RHEL/CentOS 6 32-Bit ##
wget http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
rpm -ivh epel-release-6-8.noarch.rpm

## RHEL/CentOS 6 64-Bit ##
wget http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
rpm -ivh epel-release-6-8.noarch.rpm

## RHEL/CentOS 5 32-Bit ##
wget http://download.fedoraproject.org/pub/epel/5/i386/epel-release-5-4.noarch.rpm
rpm -ivh epel-release-5-4.noarch.rpm

## RHEL/CentOS 5 64-Bit ##
wget http://download.fedoraproject.org/pub/epel/5/x86_64/epel-release-5-4.noarch.rpm
rpm -ivh epel-release-5-4.noarch.rpm

## RHEL/CentOS 4 32-Bit ##
wget http://download.fedoraproject.org/pub/epel/4/i386/epel-release-4-10.noarch.rpm
rpm -ivh epel-release-4-10.noarch.rpm

## RHEL/CentOS 4 64-Bit ##
wget http://download.fedoraproject.org/pub/epel/4/x86_64/epel-release-4-10.noarch.rpm
rpm -ivh epel-release-4-10.noarch.rpm

Как проверить репозиторий?
yum repolist

Как использовать репозиторий?
yum --enablerepo=epel info zabbix

Как устанавливать из репозитория?
yum --enablerepo=epel install zabbix

Конфигурация репозитория хранится по следующему пути:
/etc/yum.repos.d/epel.repo

06.11.2015 · XDriver · Комментариев нет
Рубрики: Linux

tcpdump на cisco ios

В режиме конфигурации:

Создаем access-list для «интересного» трафика:

router(config)#
access-list 190 permit ip 111.111.111.0 0.0.0.255 host 222.222.222.222
access-list 190 permit ip host 222.222.222.222 111.111.111.0 0.0.0.255

Настраиваем мониторинг нашего интересного трафика:

В обычном режиме:

router#
monitor capture buffer buff_name
monitor capture buffer buff_name filter access-list 190
monitor capture point ip cef filter_name all both
monitor capture point associate filter_name buff_name

Стартуем фильтр:

monitor capture point start filter_name

Просмотр дампа:

show monitor capture buffer buff_name dump

И останов фильтра:

monitor capture point stop filter_name

Сброс дампа в .pcap для анализа сниффером (например, wireshark)

monitor capture buffer buff_name export tftp://192.168.1.2/capture_dump.pcap

Сброс дампа на удаленную машину возможен только после останова активного фильтра!

Удалить фильтр:

monitor capture buffer buff_name

08.07.2015 · XDriver · Комментариев нет
Метки: , ,  · Рубрики: Cisco


%d такие блоггеры, как: